Thursday 31st August 2023

Ezoic Publisher / Login Area Ezoic Dashboards Temporarily Unavailable

[Sept 1, 01:00 UTC] - We are performing scheduled maintenance that is expected to only impact Ezoic Dashboards. During this time, publisher dashboards will be inaccessible. All ad and website related services are expected to remain fully operational during this time. The planned maintenance is expected to be completed by 02:30 UTC.

UPDATE: The maintenance window has been extended to 03:30 UTC. Thank you for your patience!

UPDATE (02:34 UTC): The maintenance window has been extended to 05:00 UTC. During this period publisher dashboards may experience outages. Thank you for your patience!

UPDATE (04:30 UTC): The maintenance period is over. All Ezoic dashboards are accessible again. All Ezoic ad and website services remained fully operational during the maintenance window.